Equipo apagado a mitad de actualización



Como  de costumbre, me gusta estar buscando actualizaciones de paquetes todos los días, es un de los comandos que suelo ejecutar en cuando conecto el equipo a internet.

Esta ocasión no fue diferente, ejecuté mi alias "actualizar" y comenzó la actualización, había un listado de paquetes, kernel, gnutls, fontconfig, glibc, entre otros. Pero el más importante, el kernel. Salí por unos minutos por café, y cuando regresé mi laptop estaba apagada.

Y ahora qué cara$%&/()(/&%$#p, y gran cantidad de cosas que dije por eso. Qué fue lo que pasó, la noche anterior había dejado la laptop con poca carga y eso ocasionó que se descargará pronto.

El gestor de paquetes (dnf actualmente) de fedora, tiene una seriae de proceso por cada actualización, que son la comprobación, descarga, ejecución y eliminación/limpieza de los paquetes obsoletos, en caso de las versiones de kernel, se elimina una cada 4 versiones, para dejar siempre 3.


El caso es que el proceso de actualización en mi laptop, se quedó en la etapa de ejecución, y no terminó correctamente la limpieza de los paquetes de versiones previas, y esto ocasionó que hubiera dos versiones instaladas del mismo paquete, provocando esto la imposibilidad de actualizar o instalar cualquier otro paquete que dependiera de los librerías de los mimos paquetes.

Lo peor de esto, fue que el kernel no se cargó al grub, por lo que en la entrada del grub no fue actualizado. En este tipo de circunstancias es en las que uno quisiera gritar de desesperación al no saber qué raios hacer.

Afortunadamente, la versión del kernel previo funcionaba correctamente, por lo tanto sí pude entrar al SO.

Al iniciar, recompilé las base de datos de rpms, eliminar los paquetes en caché, limpiar las transacciones, pero nada. El problema era que incluso al eliminar el paquete en conflicto, no funcionaba.

Ahora, si eliminaba el paquete completo, se eliminaría más de la mitad del SO, y obviamente eso no era buena idea.

Y qué hice, bueno, con la herramienta de yumex, pude listar los paquetes, y efectivamente, ahí estaban listadas ambas versiones de los mimos paquetes que estaban causando los conflictos.


Entonces, por cada paquete en conflicto, desinstalé uno, la versión más baja de la lista, es la que se debe desinstalar. E hice eso con cada paquete en conflicto.

Una vez completado, actualicé y perfecto todo. Espero y esto sea de utilidad suponiendo que les pase algo similar, alguna de las fuentes que revisé son las siguientes.

Comentarios:

@